Tethered jailbreak already available for iOS 5.1

11 March, 2012 by Elizabeth Fish, TechHive
AAA
News

Well, that was quick. Despite iOS 5.1 being available for less than 24 hours, developers at the iPhone Dev-Team blog managed to get a tethered jailbreak working, using redsn0w, for non-A5 jailbreakers on Friday.

The team originally posted a warning pre-Apple event, stating that those with jailbroken iPhones, iPods and iPads should not update, due to the possibly of a firmware update undoing your hack. Since Apple’s keynote on Thursday however, developers have worked out a ways of jailbreaking the latest iOS update for different handsets.

Anyone with an iPad 2 or iPhone 4S using iOS 5.1 can do a tethered jailbreak using Redsn0w 0.910b6, thanks to the limera1n exploit by “geohot”. Those with previous models or an iPod Touch can also try the Redsn0w jailbreak, but with caution. If you still have an old-bootrom iPhone 3GS, rejoice! You can jailbreak without needing to tether your device.

Ultrasn0w jailbreakers can also take advantage of this method until the jailbreaking software updated, but remember to use a custom IPSW rather than Apple’s (IPSW files are how iOS handsets update software). It’s worth noting that iBooks also won’t be working for a little while, until Redsn0w is updated further.

Head over the the iPhone Dev-Team blog for the Redsn0w download files and be sure to follow the instructions carefully.

6 Comments

6 people were compelled to have their say. We encourage you to do the same..

  1. Annonymous says:

    will this work for ATV2 5.1

  2. Elijah says:

    That is ridiculous. The A5 devices WILL NOT be able to be jailbroken whether unethered or tethered as of this day and time. So if you have a 4s or an ipad 2, DO NOT TRY THIS!

  3. Andrew says:

    ???
    a tethered jailbreak isn’t available for the 4s yet.

  4. Apache says:

    I am confused the above article states:

    Anyone with an iPad 2 or iPhone 4S using iOS 5.1 can do a tethered jailbreak using Redsn0w 0.910b6, thanks to the limera1n exploit by “geohot”

    Is this correct??

  5. Apache says:

    After reading the above article I am confused.

    Anyone with an iPad 2 or iPhone 4S using iOS 5.1 can do a tethered jailbreak using Redsn0w 0.910b6, thanks to the limera1n exploit by “geohot”

    So is it possible to jailbreak iPhone 4s running iOS 5.1??

  6. Andrew says:

    No. it’s a typo.

Leave a Comment

Please keep your comments friendly on the topic.

Contact us